Giới thiệu

Ở bài trước mình có giới thiệu về bộ phát wifi dành cho mọi người và nhất là các bạn yêu di chuyển về sự tiện lợi cũng như nhỏ gọn của nó. Các bạn có thể tham khảo lại ở đây Đánh giá bộ phát wifi du lịch RAVPower WD-009 FileHub

Tuy nhiên, như đã nói ở trong bài thì bộ phát này chưa hỗ trợ VPN và có tốc độ sao chép dữ liệu khá là chậm do vẫn còn sử dụng cổng USB 2.0. Chính vì vậy ở bài này mình sẽ hướng dẫn cách để có thể cài OpenWRT lên thiết bị này để các bạn có thể tùy chỉnh các chức năng mới cho nó, bao gồm cả VPN nhé.

Cách thực hiện

Các thao tác hướng dẫn trong bài viết này mình sẽ thực hiện trên máy tính Windows và trình điều khiển SSH Bitvise Client nhé. Với hệ điều hành cũng như trình điều khiển SSH khác các bạn cũng sẽ làm tương tự

Bước 1: Tải các tập tin hệ điều hành OpenWRT tại đường dẫn trang chủ của OpenWRT sau:

https://openwrt.org/toh/ravpower/rp-wd009

Hoặc các bạn cũng có thể tải trực tiếp tại đây

Bước 2: Cài đặt hệ điều hành OpenWRT

Thực hiện các bước sau theo thứ tự nhé

  • 2.1 Kết nối cổng LAN của máy tính với cổng LAN router RAVPower
  • 2.2 Đặt IP cố định của kết nối LAN trên máy tính là: 10.10.10.20 với Netmask là: 255.255.255.0
  • 2.3 Bấm và giữ phím Reset trên router RAVPower, đồng thời bấm giữ phím nguồn của Router để khởi động thiết bị lên
Cài OpenWRT cho bộ phát wifi du lịch RAVPower Filehub WD009 2
Đèn báo vào chế độ Firmware Update
  • 2.4 Sau khi đèn đã sáng ký hiệu Internet (quả địa cầu) trên thiết bị, các bạn có thể nhả phím nguồn và nút Reset ra
  • 2.5 Truy cập địa chỉ http://10.10.10.128 bằng trình duyệt trên máy tính và tiến hành tải lên file OpenWRT có đuôi .bin đã tải ở Bước 1
Cài OpenWRT cho bộ phát wifi du lịch RAVPower Filehub WD009 3
Giao diện web nâng cấp hệ thống
  • 2.6 Thiết bị sẽ tự động cài đặt và khởi động lại vào OpenWRT. Các bạn cần xóa phần cài đặt IP cố định ở Bước 2.2 để máy tính có thể nhận IP của OpenWRT

Bước 3: Cài đặt Luci Web cho OpenWRT

Phiên bản trên là phiên bản Snapshot của OpenWRT, ngay sau khi cài đặt xong sẽ cần phải kết nối Internet và cài đặt gói Luci thì mới có thể sử dụng giao diện web của thiết bị. Cùng thực hiện nhé

Chúng ta cần sử dụng Bitvise Client và kết nối với RAV qua SSH với thông tin kết nối:

  • Host IP: 192.168.1.1:22
  • Username: root
  • Password: none

Tiếp theo chúng ta sẽ cấu hình kết nối Internet qua wifi cho RAV Router theo các bước sau:

  • Mở cửa sổ Terminal SSH và gõ lệnh:
cd /etc/config
vi wireless

Sử dụng trình soạn thảo Vi để sửa các file trong OpenWRT như đã đề cập ở bài Tạo bộ phát wifi du lịch siêu an toàn từ Raspberry Pi

Tại file wireless, các bạn thêm các dòng sau vào file đó

config wifi-iface 'wwan'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'Ten-Wifi-Cua-Ban'
        option encryption 'psk2'
        option key 'Mat-Khau-Wifi'

Chú ý thay đổi 2 giá trị trong đoạn trên là Ten-Wifi-Cua-Ban là tên Wifi có sóng 2.4Ghz tại nhà bạn và Mat-Khau-Wifi là mật khẩu wifi của Wifi đó

Trong file wireless này cũng sẽ có 2 dòng có nội dung

option disabled '1'

Các bạn sửa giá trị 1 thành 0 và chúng ta sẽ được (lưu ý, có 2 vị trí cần sửa)

option disabled '0'

Sau đó lưu lại và thoát ra và tiếp tục chỉnh sửa file network

vi network

Xóa hết dữ liệu và dán nội dung sau vào file network đó

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd51:d643:7bbf::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option force_link '1'

config interface 'wwan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '94.140.14.14 94.140.15.15'

config interface 'vpnclient'
        option ifname 'tun0'
        option proto 'none'

Tiếp tục thoát ra và chỉnh sửa file firewall

vi firewall

Tìm đoạn có nội dung sau

config zone                                                                                                                  
     option name             wan                                                                                          
     list   network          'wan'                                                                                        
     list   network          'wan6'                                                                                       
     option input            REJECT                                                                                       
     option output           ACCEPT                                                                                       
     option forward          REJECT                                                                                       
     option masq             1                                                                                            
     option mtu_fix          1   

Và sửa lại thành

config zone                                                                                                                  
     option name             wan                                                                                          
     list   network          'wan'                                                                                        
     list   network          'wan6'
     list   network          'wwan'                                                                                     
     option input            ACCEPT                                                                                       
     option output           ACCEPT                                                                                       
     option forward          REJECT                                                                                       
     option masq             1                                                                                            
     option mtu_fix          1   

Lưu lại và thoát ra, sau đó chúng ta kích hoạt wifi bằng 2 câu lệnh dưới đây

ifconfig wlan0 up
ifconfig wlan1 up

Tiếp theo là tiết hành khởi động lại hệ thống router bằng câu lệnh

reboot

Sau khi khởi động lại thì chiếc RAV Router của chúng ta đã có kết nối Internet, các bạn có thể thấy dễ dàng biểu tượng Wifi nhấp nháy sau khi nó được khởi động lên. Tiến hành đăng nhập lại SSH và cài đặt Luci web thôi nào

Tại cửa sổ lệnh chúng ta chạy câu lệnh sau để tiến hành cài đặt Luci

opkg update
opkg install luci luci-ssl
/etc/init.d/uhttpd restart

Sau khi chạy xong, các bạn có thể truy cập trình quản lý OpenWRT bằng giao diện web Luci tại địa chỉ: http://192.168.1.1

Kết luận

Trên đây mình đã hướng dẫn các bạn các bước để cài đặt OpenWRT trên chiếc Router du lịch RavPower WD009. Với hệ điều hành này thì các bạn có thể tùy chỉnh cấu hình cũng như cài đặt thêm các tiện ích nếu cần thiết. Các bạn có thể tham khảo bài viết Tạo bộ phát wifi du lịch siêu an toàn từ Raspberry Pi để cài đặt VPN trên con Router này. Hoặc mình sẽ có bài viết khác hướng dẫn cách cài đặt VPN và NAS server trên con Router này sau. Cảm ơn các bạn đã đọc đến giai đoạn này. Nếu có bất kỳ câu hỏi gì về cài đặt, hãy để lại bình luận để chúng ta cùng thảo luận nhé

Giới thiệu về tác giả

Việt Nguyễn

Người viết blog

Mình là Việt, mình 28 tuổi và lý do mà mình mở blog này chính là chia sẻ những kinh nghiệm, trải nghiệm mà bản thân đã khám phá được tới mọi người

Xem tất cả các bài viết